Discussie forum over weatherlink software. Voor vragen, specificaties, ervaringen etc..

#71998
Beste weervrienden,

Na een nieuwe Davis VP2 Plus incl datalogger te hebben aangeschaft heb ik upload problemen.
Voor de volledigheid hierbij een opsomming van mijn oude setup (vanaf 2006-2020 maart):
-Davis VP2 Plus met serial datalogger (firmware 1.9)
-WeatherLink (upgrades tot 6.0.4)
-VirtualVP 1.2.5
-Lavalink Serial2Ether ( https://lavaports.com/ether-serial-link ... s-232-db9/ )
-Lava Ether Link Manager
-Windows XP Professional
-Fit-PC Slim ( https://en.wikipedia.org/wiki/Fit-PC#fit-PC_Slim )

Dit alles heb ik zodanig aan elkaar geknoopt dat het signaal van de seriële datalogger rechtstreeks naar de Serial2Ether converter gaat. Dit signaal "zit" nu via het ethernet signaal als een IP-device op mijn LAN. Op mijn weer-pc-tje pik ik dat signaal op en met s.w. Lava Ether Link Manager maak ik er weer een serieel signaal van.
Met VirtualVP maak ik van dit serieel signaal "meerdere" serieele/ip-signalen om naast Weatherlink ook Cumulus te voorzien van data. ook kan ik op een 2de pc het truukje uithalen om via IP het signaal op te pikken en aanbieden aan WeatherLink/Cumulus/andere experimentele weer s.w. Dit heeft jaren goed gewerkt.

Het "buiten"-spul van 2006 was sinds begin deze maand echt aan vervanging toe, ik had heel veel storingen, windmeter, regenmeter, en elektronica van de ISS hadden het begeven. De knoop doorgehakt en een geheel nieuwe set aangeschaft, hopelijk gaat ie weer jaren mee :D

Dit is mijn nieuwe setup (vanaf 2020 maart):
-Davis VP2 Plus met serial datalogger (firmware 3.15)
-etc.... zie boven

Maar nu heb ik een probleempje met de upload in WeatherLink naar lokale schijf (mapje) en internet.
WeatherLink geeft onderstaande foutmelding:

13-03-20 18:46 (WXHoogeloon) Unable to upload Data Upload Profile(s) 1 because of errors. See error messages below.
13-03-20 18:46 (WXHoogeloon) Error reading data from the Station.
13-03-20 18:46 (WXHoogeloon) We did not receive an acknowledge to our last command. Please try again.
13-03-20 18:46 (WXHoogeloon) GetAcknowledge () response: 0x0A (should be 0x06 <ACK>)


Dus op de een of andere manier stuurt WeatherLink een commando naar de nieuwe console/datalogger en verwacht ie een antwoordt terug. Bij de oude console/datalogger had ik dit probleem niet.
Heb nu mijn oude console/datalogger combinatie maar weer aangesloten naast de nieuwe, maar dat is niet wat ik wil. Heb tenslotte niet voor niks een nieuwe console en datalogger aangeschaft.

Wie herkent dit probleem? Wat is de oplossing?
Alle info is welkom.
#72000
Helaas herken ik het probleem ook. Dit is normaal met combinatie met virtualvp en weatherlink.
- Krijg je deze foutmelding bij elke download? Bij mij gaat het in ongeveer 50% van de regels fout. De rest gaat wel goed.
- Oplossing heb ik nog niet gevonden. Wel ben ik teruggegaan naar WL 5.8.3. Deze gaf op dat moment minder problemen.
- soms helpt bij mij ook pc opnieuw opstarten als er erg vaak foutmeldingen zijn. Hierna wordt het wat minder.
#72008
wsepe schreef: 14 mar 2020, 17:50 Helaas herken ik het probleem ook. Dit is normaal met combinatie met virtualvp en weatherlink.
- Krijg je deze foutmelding bij elke download?
Ja, Weatherlink geeft bij elke download deze foutmelding. En het maakt ook niet uit of welke versie van WeatherLink ik gebruik.
Dus mijn gedachte: Het heeft iets te maken met de laatste nieuwe datalogger en de combinatie VirtualVP.
Heb de nieuwe console/datalogger als proef aangesloten aan een laptop met WeatherLink 6.0.5 (laatste versie) via een USB to Serial Converter http://www.sitecomlearningcentre.com/nl ... /downloads met als resultaat: alles werkt gewoon.

wsepe schreef: 14 mar 2020, 17:50- Oplossing heb ik nog niet gevonden. Wel ben ik teruggegaan naar WL 5.8.3. Deze gaf op dat moment minder problemen.
Is voor mij geen optie, omdat deze versie geen upload naar WeatherLink.com in zich heeft.

wsepe schreef: 14 mar 2020, 17:50- soms helpt bij mij ook pc opnieuw opstarten als er erg vaak foutmeldingen zijn. Hierna wordt het wat minder.
Heb ik niet geprobeerd.

Kan je beamen dat deze 'problemen' veroorzaakt worden door de combinatie nieuwe datalogger versus VirutualVP?
Dan kan ik de serial3ethernet converter namelijk uitsluiten als de veroorzaker van de 'problemen'
Alvast dank,
#72016
weerstationhoogeloon schreef: 15 mar 2020, 20:20 Dus mijn gedachte: Het heeft iets te maken met de laatste nieuwe datalogger en de combinatie VirtualVP.
Het lukt mij nu even niet om mijn firmware versie uit te lezen, maar ik ben even aan het zoeken gegaan. Volgens https://www.wxforum.net/index.php?topic=33942.0 gaat inderdaad de firmware 3.15 niet werken met VVP.
#72024
wsepe schreef: 17 mar 2020, 00:49 ...Volgens https://www.wxforum.net/index.php?topic=33942.0 gaat inderdaad de firmware 3.15 niet werken met VVP.
heb de link van WSEPE gelezen en ook daar wordt gesteld dat met firmware 3.15 VirtualVP niet werkt.
Ik zal eens gaan kijken wat ik met http://www.eterlogic.com/Products.VSPE.html Etherlogic VSPE kan bereiken.
Heb een 32-bits weer-pc dus dat zou dan ook nog eens de free versie zijn van VSPE zijn.
Zodra ik wat meer tijd heb ga ik hiermee aan de gang, voorlopig draait alles nog met de oude console/datalogger combinatie.
Bedankt voor de tip!
#72035
whozee schreef: 23 mar 2020, 11:23 Hier VVP 1.2.5.74 op Davis datalogger Envoy firmware versie 3.80.
Eveneens gekochte versie Eterlogic Virtual Serial ports Emulator versie 64 bits 2.0.38
Ik ben gebonden aan de 32 bits versie omdat mijn pc een 32-bits processor heeft.

whozee schreef: 23 mar 2020, 11:23Alles draait op Windows 10 64 bits zonder problemen.
Dat is goed om te horen. Kan je mij wat tips geven hoe ik Etherlogic Virtual Serial ports Emulator en VirtualVP het best kan instellen om deze 2 s.w. pakketten tesamen kan laten draaien, zodat ik weer meerdere weer-s.w. (WeatherLink, Cumulus, VPLive) kan gebruiken? Eventueel met wat plaatjes?

whozee schreef: 23 mar 2020, 11:23Windows XP wordt niet meer ondersteund, maar dat wist u vast al.
Ja, is bekend. Maar de combinatie met een energiezuinige mini-pc/windows XP draait super.
#72037
Hier dus hardware:
Dell Optiplec7050 mini pc met 8GB ram 256ssd
Davis Vp2 +.via serieel naar usb converter aan de Davis Envoy
Allen met laatste firmware.

Software:
Windows 10 home 1909 64 bits.
Weatherlink 6.05
Alle software up to date bijgewerkt.
U hangt 24 uur aan het net. Dat net is verbonden met de hele wereld!

VSPE:download/file.php?mode=view&id=7257

VP:
download/file.php?mode=view&id=7256
Bijlagen
VPSE.png
VSPE configuratie.
VPSE.png (113.56 KiB) 959 keer bekeken
VP setting.png
VP setting.png (395.16 KiB) 959 keer bekeken
#72054
Heb even een laptop vrijgemaakt om eea te kunnen testen om de combinatie met VSPE, VVP en Weatherlink te kunnen laten draaien.

Laptop is een wat oudere Acer 64Bits 4Gb RAM, 400Mb HDD en W10 Home edition.
Heb daarop WeatherLink 6.0.5, VirtualVP 1.2.5.74, VSPE 0.941.5.179 en Cumulus 1.9.4 geinstalleerd.
De verbinding met de seriële datalogger is middels een Sitecom serial2usb CN-104 v4 001 http://www.sitecomlearningcentre.com/nl ... /downloads.

Heb alles precies ingesteld zoals de screenshots laten zien, dit zijn mijn instellingen:
Aantekening 2020-03-29 194742.jpg
Aantekening 2020-03-29 194742.jpg (50.22 KiB) 893 keer bekeken
Aantekening 2020-03-29 195438.jpg
Aantekening 2020-03-29 195438.jpg (41.66 KiB) 893 keer bekeken
Aantekening 2020-03-29 195310.jpg
Aantekening 2020-03-29 195310.jpg (81.63 KiB) 893 keer bekeken

Helaas werkt het niet en blijf ik foutmeldingen genereren in WeatherLink:

29-03-20 19:40 (WXHoogeloon) Unable to upload Data Upload Profile(s) 1 because of errors. See error messages below.
29-03-20 19:40 (WXHoogeloon) Error reading data from the Station.
29-03-20 19:40 (WXHoogeloon) We did not receive an acknowledge to our last command. Please try again.
29-03-20 19:40 (WXHoogeloon) GetAcknowledge () response: 0x0A (should be 0x06 <ACK>)
29-03-20 19:40 Downloaded WXHoogeloon ok.
29-03-20 19:39 (WXHoogeloon) Unable to upload Data Upload Profile(s) 1 8 because of errors. See error messages below.
29-03-20 19:39 (WXHoogeloon) Error reading data from the Station.
29-03-20 19:39 (WXHoogeloon) We did not receive an acknowledge to our last command. Please try again.
29-03-20 19:39 (WXHoogeloon) GetAcknowledge () response: 0x0A (should be 0x06 <ACK>)
29-03-20 19:39 Downloaded WXHoogeloon ok.


Ergens gaat er iets mis, maar ik weet niet wat. Enig idee?