Oftewel het 'knutsel' forum.
Heb je zelf een weerstation gemaakt, een eigen weer hut gebouwd? Of misschien een webcam? Deel dan hier ervaringen, (bouw-)tekening etc...
Gebruikersavatar
Door Toulon7559
#74328
Waarschijnlijk kleinigheid, maar oplossing nog niet gevonden .....

Mijn GW1000 verzamelt de data van momenteel 8* T&H-meter WH31A, 1* Regenmeter WH40 en 1* Bodemvochtsensor WH51.
GW1000 levert netjes de info af aan de Ecowitt-website en aan een Meteobridge,
maar de sensordata ook gewenst voor lokale toepassing.
Voor deze realisatie ook i.v.m. streven 'meer PHP' een Raspberry voorzien van Raspian_Bullseye, Apache2 en PHP7.4
Die Raspberry werkt goed met PHP-test-scripts die verwachten dat een bericht binnenkomt met data cf. Ecowitt-protocol.
Bijv. de externe aanroep http://192.168.0.198/index.php vanuit de browser van een PC geeft in de Raspberry een gedateerde txt-file:
weliswaar die txt-file zonder realistische data-inhoud, maar dat is te verwachten als er geen begeleidende data is.
Alle betrokken computers op zelfde (W)LAN met IP-range 192.168.0.x

De Customixed upload van GW1000 nu bijpassend ingesteld.
.
IMG_20221024_GW1000 [640x480].jpg
GW1000, Customized Upload
IMG_20221024_GW1000 [640x480].jpg (31.33 KiB) 374 keer bekeken
.
Met die instellingen loopt echter blijkbaar de data-upload van de GW1000 niet, want er verschijnt op de Raspberry geen resulterende txt-file.
[Na Save voor de settings zie ik aan de tekst onderaan de webpage dat upload zou kunnen.
Soms (maar meestal niet) verschijnt na Save even een kleine, zwart/grijze widget met melding Success]

.
Blijkbaar mist er iets m.b.t. de instellingen van de GW1000 Customized upload, maar wat?
Gebruikersavatar
Door Toulon7559
#74330
De widget genoemd in mijn vorige bericht (b)lijkt toch verband te hebben met de acceptatie van de instellingen door GW1000 voor Customized upload.
Vanmiddag nog een keer instellingen voor een klein test-script gesaved,
t/m verschijning van bevestigingswidget => daarna dat kleine test-script met goed resultaat op gang (= periodieke, complete uitlezing van het GW1000-bericht).
Komt de widget niet op na Save, dan geen opstart vanuit GW1000, en bij opnieuw kiezen van WSView valt de instelling terug naar vorige versie: bekend verschijnsel? Verklaring waarom vaak niet geaccepteerd?

Vervolgstap is test_met_succes met een uitgebreider script dat een hele collectie datafiles kan leveren als vertaler & voorzet voor data-verdeling en data-extractie in diverse richtingen.
Path voor GW1000 mag daarbij een lange versie zijn zoals genoemd in het uitgebreidere script.