Discussie forum met algemene vragen over weerstations niet gerelateerd aan een merk uit de andere forums
Door engelbert.jan
#72405
Goedenmiddag

Ik heb pws_dasboard geinstalleerd in de root. Nu krijg ik soms een error bij het openen van de link:
https://weerstationbijdetoren.nl/pwsWDxx/index.php
Moet soms deze link een aantal malen in toetsen voordat ik "op" de website kom.
provider: hosting4ever
pc: linux-mint
gebruik nu nog: WU
error.jpeg
error.jpeg (42.93 KiB) 415 keer bekeken
volgende issue is:
Lufdaten krijg soms een melding: Problem 87:No valid data fround, script ends
zie ook: https://www.weather-watch.com/smf/index ... #msg560837
heb dus deze tip al uitgevoerd.
Wie heeft tips.

Alvast bedankt
Gr Engelbert
Gebruikersavatar
Door wvdkuil
#72406
engelbert.jan schreef: 07 aug 2020, 14:42 Goedenmiddag
Ik heb pws_dasboard geinstalleerd in de root. Nu krijg ik soms een error bij het openen van de link:
https://weerstationbijdetoren.nl/pwsWDxx/index.php
Moet soms deze link een aantal malen in toetsen voordat ik "op" de website kom.
provider: hosting4ever
pc: linux-mint
gebruik nu nog: WU
error.jpeg
volgende issue is:
Lufdaten krijg soms een melding: Problem 87:No valid data fround, script ends
zie ook: https://www.weather-watch.com/smf/index ... #msg560837
heb dus deze tip al uitgevoerd.
Wie heeft tips.
Alvast bedankt
Gr Engelbert
ERROR 500 Internal server error
Die komt soms/vaak voor bij alle scripts, niet alleen bij het start-script.
Met een tweede keer hetzelfde script uit te voeren gaat het meestal goed.

Uw data die u terug krijgt van WU is nogal incompleet. Maar zover ik kan zien is dat niet het probleem.

Wel zijn er diverse problemen te zien op https://www.weerstationbijdetoren.nl/pw ... e_test.php
Druk op de knop "Load files" en wacht minstens 10 secondes.
De Luftdaten sensor website geeft(vaak?) geen antwoord (meer) https://data.sensor.community/airrohr/v1/sensor/30119/
Code: Selecteer alles
time spent: 10.0026 -  invalid CURL Connection timed out after 10000 milliseconds 
Dus beter even de Luftaten sensor in easyweathersettings uit zetten totdat we weten wat er aan de hand is.

De onderste drie regels om de WU gegevens op te halen geven ook een 500 error, op een eigen script.
Maar als ik dit script in de browser uitvoer => geen probleem
https://weerstationbijdetoren.nl/pwsWDx ... r&format=1
Nog enkele keren proberen en er komt weer een 500 error. Allemaal heel vreemd.

STAP 1:
Wellicht vindt u de oorzaak van de errors in de error-logs bij uw provider. Die moeten aangeven welk script die 500-error heeft veroorzaakt.
STAP 21:
Zet in ieder geval even de CDN uit in uw control panel
cdn.jpg
cdn.jpg (26.72 KiB) 404 keer bekeken
STAP 3:
Als er geen gegevens in de error-logs staan, de CDN uitzetten ook niet helpt, kan ik hier naar gaan zoeken op uw website. Maar dan heb ik de ftp gegevens nodig zodat ik stap voor stap kan testen.
Ik zal een nieuwe installatie maken met een andere map naam, uw settings overnemen en dan klein stapje voor stapje zien waar het voor het eerst fout loopt.

Die FTP user en password kunt u mij via e-mail sturen. Dus niet posten hier op het forum.
U kunt dan later het FTP password wijzigen.

Wim
Gebruikersavatar
Door wvdkuil
#72410
Ik heb no g een andere test gedaan.
  • Het goedkoopste abonnement bij uw provider genomen.Werkelijk zeer compleet voor €6.53 incl BTW / jaar.
  • Een tijdelijke naam http://testing4ever-nl.cphosting4ever.nl/
  • In het control-panel FTP aangezet.
  • De voor-laatste versie opgeladen en getest - de nog niet uitgegeven versie opgeladen en getest
  • Alles zoveel mogelijk met uw settings zoals WU-ID en de zichtbare teksten gebruikt
En alles werkt zoals het hoort tot nu toe:
Dus met uw incomplete WU-data, wel zonder Luftdaten maar dat kan ook niet de oorzaak zijn van de error 500.
Geen CDN want dat zit niet in de goedkoopste versie

Dus mijn vragen:
  • Wat heeft u ingevuld bij uw startdatum van opladen naar WU? Controleer of er daar soms YYYY-MM-DD staat en zet daar bijvoorbeeld even 2019-01-01
  • Heeft u soms eerst Wordpress of iets dergelijks geïnstalleerd voordat u PWS_Dashboard ging installeren? Zo ja heeft u dan de Wordpress security aan staan?
Meer kan ik nu niet verzinnen want het werkt gewoon goed.

Wim
Gebruikersavatar
Door wvdkuil
#72413
Goede morgen,

Kunt u a.u.b. de error log vanuit uw control panel downloaden?
Zie bijgevoegd screenshot.
nl_log.jpeg
nl_log.jpeg (34.18 KiB) 369 keer bekeken
error-log.jpeg
error-log.jpeg (64.11 KiB) 369 keer bekeken
Nog steeds krijgt u die "Internal Server Error" 1 of enkele keren als uw website na een tijdje weer eens wordt gestart. https://weerstationbijdetoren.nl/pwsWDxx/index.php
Met die log kan ik waarschijnlijk zien wat de error 500 bij u veroorzaakt.
Het is me niet gelukt die op mijn test-site bij hosting4ever ook te krijgen.

Ik wil zeker weten dat er geen verborgen fout in de PWS_Dashboard scripts zit voordat ik het nieuwe Augustus release on-line zet.

Wim
Door engelbert.jan
#72414
Goedemiddag,

Bedankt voor deze ondersteuning. Wil wel in de nabije toekomst over naar ecowitt upload.
Maar hierbij de logbestand.
Als ik iets kan betekenen stuur dan een berichtje.
Succes

Gr Engelbert
Gebruikersavatar
Door wvdkuil
#72415
engelbert.jan schreef: 08 aug 2020, 12:27 Goedemiddag,

Bedankt voor deze ondersteuning. Wil wel in de nabije toekomst over naar ecowitt upload.
Maar hierbij de logbestand.
Als ik iets kan betekenen stuur dan een berichtje.
Succes

Gr Engelbert
Helaas zie ik geen bestand bij uw bericht.
Kunt u het alsnog als bijlage toevoegen?

Wim
Door engelbert.jan
#72416
even een aanvulling.
ik gebruik geen wordpress en heb de WU-datum op 2019-01-01 gezet.
Het vorige bericht had geen logbestand i.v.m. dit was te groot ( foutje aan deze kant van de lijn :o )
(502.6 KiB) 14 keer gedownload
Succes
Engelbert
Gebruikersavatar
Door wvdkuil
#72417
engelbert.jan schreef: 08 aug 2020, 13:21 even een aanvulling.
ik gebruik geen wordpress en heb de WU-datum op 2019-01-01 gezet.
Het vorige bericht had geen logbestand i.v.m. dit was te groot ( foutje aan deze kant van de lijn :o )
error1_log.txt

Succes
Engelbert
Helaas totaal onbekende foutboodschappen, nooit gezien. Weinig info op Google over te vinden
In principe zou u w website op dezelfde fysieke webserver moeten draaien als mijn test-versie.

Maar u krijgt werkelijk honderden foutboodschappen die normaal gesproken helemaal niet kunnen:
Code: Selecteer alles
SoftException in Application.cpp:258: File "/home/sites/3b/7/7f63b5d303/public_html/pwsWDxx/index.php" is writeable by others
SoftException in Application.cpp:585: Directory "/home/sites/3b/7/7f63b5d303/public_html/pwsWDxx" is writeable by others
Een script wordt m.b.v. uw FTP programma opgeladen met "permissie" 644
Alle scripts hebben dat bij http://testing4ever-nl.cphosting4ever.n ... /index.php
Uw startmap pwsWDxx heeft ook een veel te hoge permissie. Die mag niet hoger zijn dan 755

Verder lopen nog steeds allerlei scripts NA DE VORIGE FOUT in een andere fout
Code: Selecteer alles
End of script output before headers: index.php
End of script output before headers: PWS_DailyHistory.php
Ik weet niet hoe dit kan voorkoment.
Ik kan ook niets zien wat hierop lijkt op de test-server.

VRAAG Kunt u met uw FTP programma nakijken wat de ingestelde permissies zijn?
VRAAG Misschien heeft u iets te enthousiast wat extra zaken in het ControlPanel aangezet?
VRAAG Heeft u misschien met uw FTP rpogramma alle mappen en hun inhoud op 777 gezet?

Vanop afstand kan ik alleen maar raden want helaas zijn programmeurs niet helderziend.

Wim
Door engelbert.jan
#72421
Bedankt voor deze uitleg.
Ik ben altijd zeer enthousiast om iets nieuws te leren. Maar om de ingestelde permissies te wijzigen zo enthousiast ben ik nu ook weer niet. Dus geen idee hoe dit komt.
Ik wil wel graag meedenken.
Zal u binnenkort een PM sturen. Kunt u zelf kijken en eventueel aanpassen.
Gr Engelbert
Gebruikersavatar
Door wvdkuil
#72422
engelbert.jan schreef: 09 aug 2020, 11:14 Bedankt voor deze uitleg.
Ik ben altijd zeer enthousiast om iets nieuws te leren. Maar om de ingestelde permissies te wijzigen zo enthousiast ben ik nu ook weer niet. Dus geen idee hoe dit komt.
Ik wil wel graag meedenken.
Zal u binnenkort een PM sturen. Kunt u zelf kijken en eventueel aanpassen.
Gr Engelbert
Het lijkt erop dat - in ieder geval een deel van - de problemen zijn opgelost?
https://www.weerstationbijdetoren.nl/pw ... e_test.php
=> knop "Load files" geen foutboodschappen meer.
Wat was het probleem?

===
Helaas de "Internal Server Error" is er nog steeds.
De toegestuurde FTP userid en password werken niet.
S.v.p. nog eens controleren of er geen typefout is.

Wim