Discussie forum over de Meteobridge / Meteohub. Voor vragen, specificaties, ervaringen etc..
Door kluijfhout
#72198
Ik ben al enige jaren in het bezit van een ELRO C803IP.2 camera
Ik wil de beelden hiervan op mijn weerwebsite zetten.
In een ander forumbericht werd netjes uitgelegd hoe deze te configureren in meteobridge.
Helaas krijg ik de volgende foutmelding:
Error: Camera URL not providing data: http://admin:xxxxxx@192.168.0.xx/cgi-bi ... pas=xxxxxx
Ik kan echter in de camerasoftware geen instelling vinden die het mogelijk maakt om snapshot 'aan' te zetten.
Betekent dit dat deze camera niet geschikt is om in meteobridge te gebruiken?
camera.JPG
camera.JPG (26.3 KiB) 579 keer bekeken
Gr, johan
Door heersje
#72199
het adres dat je invult in MB moet ook buiten meteobridge een beeld geven in een browser zonder speciale software te installeren, het enige is dat er een overlay over heen gaat via MB. Er worden vrij veel formats ondersteund.
Gebruikersavatar
Door T.J.
#72204
Hallo Johan.

Ik heb een 903 van elro en dit werkt goed.
Je moet een extensie gebruiken met snapshot.cgi als path.
Je hebt namelijk snapshot.cgi, dus een foto opdracht en je hebt videostream.cgi voor live video.
Echter moet je wel een poort forwarden in je router.
Ik gebruik poort 554
Ik heb in de configuratie van de cam een gebruiker aangemaakt webcam, ww webcam.(niks geheim aan hoor)
Link wordt dan:
http://webcam:webcam@XX.XXX.XX.X:554/sn ... wd=webcam) hoeft er niet achter, maar ik doe dat wel...

Het XXXXXXXXXXX adres is mijn WAN IP adres
:554 is uiteraard het poortnummer en dus wordt je extern naar het IP adres 192.168.1.122 verwezen welke mijn ip adres is intern van de cam.
Ik heb de webcam een vast IP adres gegeven zodat de poort altijd naar het juiste device verwijst.
:554 erachter verwijst naar het poortnummer, 554 is gebruikelijk voor streamen.
Ook handige documentatie vindt je hier, betreffende Elro camera's en adressen.
https://www.ispyconnect.com/man.aspx?n=elro&page=1

Probeer eerst maar eens je lokale ip adres van je cam, in mijn
geval dus 192.168.1.122 en daar de extensie snapshot.cgi aan te plakken. Dus zoiets als:
http://192.168.1.122:554/snapshot.cgi
Of voor stream:
http://192.168.1.122:554/snapshot.cgi
Let wel dat je de poortnummer erachter plakt. (:554) anders werkt het niet.
Voor meteobridge je WAN ip adres gebruiken en niet je lokale adres(192.168.1.xxx), de router zal de request naar de juiste IP adres intern leiden door je port forwarding.


Succes.
Door heersje
#72209
Hallo Johan,

Ik heb niet zo een camera als jij maar weet je zeker dat je dat poortnummer bij intern gebruik nodig hebt? Normaal doe je met port forwards OP JE ROUTER - een poortje openzetten (poortje 554) dat gelinkt wordt aan het IP adres van je camera op de poort van de camera waar het beeld te vinden is. Heel vaak zal er op je camera een webserver draaien op de standaard poort 80. Kijk eens met whatismyip.com wat je huidige externe IP adres is. Surf dan eens naar dat externe_ipadres:554/snapshot.cgi (-of-hoe-dat-ook-bij-jouw-camera-heet,evt met je telefoon).

De eerste stap voor jou is nu het precieze interne adres te vinden waarop je een beeld van de camera krijgt in een browser (zonder speciale software). Vervolgens koppel je een poort op de router aan het ipadres:poort van de camera waar je beeld hebt. Vervolgens check je dat met je externe ip adres en ingestelde poort. Pas als dat beeld oplevert zet je dat laatste adres in je MB en definieer je overlay velden.

Let op je externe IP adres zou af en toe kunnen wijzigen, dat ligt aan je provider

succes Jean-Paul
Door kluijfhout
#72211
http://weerstation:090462@192.168.0.57/snapshot.cgi geeft wel een positief resultaat, maar ik weet niet of dit juist is
camera.JPG
camera.JPG (26.31 KiB) 526 keer bekeken
want in tab 'netwerken' krijg ik een zwart beeld (bij het eerste lensje, 2e lensje geeft 'The requested URL was not found on this server.'
camera2.JPG
camera2.JPG (29.1 KiB) 526 keer bekeken
http://weerstation:090462@xx.xxx.xx.xxx ... pas=090462 geeft geen resultaat
(xx.xxx.xx.xxx = mijn externe ip adres)
Gebruikersavatar
Door T.J.
#72212
De link via de MB kan even duren eer het resultaat zichtbaar wordt:

Ik heb in mijn MB het volgende staan bij de URL:

http://webcam:webcam@XX.XXX.XX.X:554/sn ... pwd=webcam

Probeer eens gewoon wat ik heb staan alleen je eigen WAN en user en pwd, dus geen pas en geen userlogin

Dus wel de user en pwd achter de extensie.

Als ik in firefox het poortnummer achterwege laat dan krijg ik geen verbinding.
Met de :554 gaat dat prima, ik heb overigens een Sitecom router....misschien dat het router gerelateerd is...
Dus probeer ook eens lokaal zonder de 554 vermelding.
Door heersje
#72213
Hallo Johan,

Kijk naar de stappen die ik hierboven aangeef. Je moet via je externe ip adres op de ingestelde poort de camera opname zien. Als dat niet mogelijk is dan is je router niet goed ingesteld. Je kunt geen intern ip adres in MB opgeven. De meteobridge server moet er bij kunnen.

Succes
Door kluijfhout
#72214
Het probleem is dat mijn camera de door mij ingestelde gebruikers niet onthoudt en teruggaat naar zijn fabrieksinstellingen.
Er is 1 gebruiker: admin en zonder wachtwoord.
Kan ik dit ook gebruiken of heb ik echt een wachtwoord nodig?
Volstaat dan een spatie--> http://admin: @...... ??
Zo niet, dan zit er niks anders op dan een nieuwe camera aan te schaffen.

Dit is de instelling in mijn router:
Screenshot_20200516-221058_Deco.jpg
Screenshot_20200516-221058_Deco.jpg (106.61 KiB) 484 keer bekeken
Door heersje
#72215
Hallo Johan, even volhouden het moet werken net als bij Tjeerd ook al heeft hij een iets ander type, en je hebt de eerste stap voor elkaar. Het probleem zit denk ik in je routerinstellingen daar gaat een andere camera niet mee helpen denk ik.

1.Het is je gelukt om met je browser naar een intern adres te gaan, en je ziet de snapshot van de camera. Het maakt niet uit voor het principe of en welke user en wachtwoord je hier voor gebruikt. Een spatie in een url zal nooit werken, misschien admin@.... of alleen ip of moet je user en pw er achter zetten, zie bericht Tjeerd.

2. je past de router aan zodat de gekozen externe poort (554 in jouw geval) doorverwijst (port forwarding) naar het interne ip adres. Ik neem hierbij aan dat je voor het interne adres van stap 1 geen poort hoefde te vermelden in je browser. Je kunt in je router als (optionele) poort 80 invullen.

3.via whatismyip.com achterhaal je je externe IP adres. Je kopieert EXACT het interne adres van stap 1 inclusief wachtwoord en gebruiker in je browser. Maar je vervangt het interne ip adres door het externe ip adres met het poort nummer. Dus bijvoorbeeld 100.200.300.400:554.

4. als de voorgaande stap de snapshot oplevert in je browserkopieer je dit adres volledig in meteobridge.

5. is dan de overlay definieren, daar kun je op dit forum wel wat over vinden denk ik.

Dus stap voor stap werken.

Succes